I was specifically told by my boss to make all the save/load buttons say "save one" "load one" "save two" etc. Then this fuckwit decided that there was no particular reason for them being named the way they were, and switched them to "slot one" "slot two" etc. I checked with the designer, and he agreed with what my boss first told me, so back they go. I'm not going to even bother asking them about reverting the change that greyed out buttons should be slectable but give an error sound, as opposed to this morons intepretation that the cursor should just skip over them.
I don't care if he's a decent programmer, he's an annoying, demanding twit, and i want to rip his fucking throat out!